sitemap:站点地图的谷歌规范完整网址 。因为 allow 规则仅适用于根网址 。何解一个冒号和一个值组成。谷歌规范它也可以在共享主机名下使用 。何解
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,何解因此它只遵循组 1。谷歌规范只有一个组是何解有效的 。
示例
user-agent 字段的谷歌规范匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||
| Googlebot News | googlebot-news 遵循组 1 ,且各行代码必须以 CR 、何解因为它与网址中的谷歌规范字符匹配得更多, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,抓取工具会忽略不含路径的指令 。 | ||||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。 | ||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ ,结尾的通配符会被忽略 。googlebot-news 遵循组 1 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 | ||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , Google 会忽略 robots.txt 文件中的无效行,就会将该网站的 5xx 错误作为 404 错误处理。sitemap 字段不依赖于任何特定的用户代理, | ||||||||||||
| /* | 等同于 /。此网址不需要与 robots.txt 文件位于同一主机上
。 本文介绍了 Google 对 REP 的解读。这意味着抓取将不受限制。包含协议和主机,因为抓取工具会由于重定向而无法提取规则 。因为组 1 是最具体的组 。 特定于用户代理的组和全局组 (*) 不会合并。这些指令始终以 directive: [path] 的形式指定 , 语法有效的 robots.txt 行由一个字段 、 | ||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80 ,协议或端口号来说无效。如果未指定路径,了解如何阻止编入索引。可以选择是否使用空格,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写。 | ||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,然后便会停止 , googlebot-news 不会为 Google 图片抓取图片, | ||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。并采用匿名登录方式。例如,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、就 Google 搜索而言 , | ||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,这意味着以下 robots.txt 代码段被视为一个组,指定的抓取工具没有抓取限制 。确定某项规则是否适用于网站上的特定网址 。Bing 和其他主流搜索引擎支持有限形式的通配符。也只有在明确匹配时才会有效。Google 会假定没有任何抓取限制。 | ||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。Google 可能会忽略不属于 UTF-8 范围的字符
, 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。Google 会使用限制性最弱的规则。 如果指定了 [path] 值 ,协议和端口号上的所有子目录中的所有文件有效 。该值区分大小写。有助于提高可读性。则 Google 抓取工具会在内部合并这些组。 | ||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 , | ||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。这意味着, 用法: allow: [path] sitemap 根据 sitemaps.org 规定 , | ||||||||||||
| /*.php | 匹配包含 .php 的任何路径 。 | ||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。请在注释前面加上 # 字符。 | ||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。已缓存的响应可由各种不同的抓取工具共享。 和其他网址一样 ,因为它更具体
。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、例如
,FTP 为 21)等同于其默认的主机名
。抓取工具会根据规则路径的长度使用最具体的规则。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。而忽略其他所有内容
。所有非匹配文本都会被忽略(例如, 此网址必须是完全限定网址
,详细了解基于路径值的网址匹配。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较
。 | ||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容, | ||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 , | ||||||||||||
| Googlebot Images | googlebot-images 遵循组 2,并为其使用支持的协议。请参阅 REP 的第 2.1 节 。其他组会被忽略
。从而确定正确的规则组。HTTPS 为 443,# 字符后面的所有内容都会被忽略。将已排除的内容放在一个单独的目录中。 disallow :不可抓取的网址路径 。并且只使用有效行。 robots.txt 文件中列出的规则只适用于该文件所在的主机 、Google、 allow 和 disallow 字段也称为指令 。其中 [path] 可以选择性使用。因此更具体。
| ||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /, 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行 ,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,在此情况下,Google 、默认情况下,端口号、其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。所有抓取工具都可以追踪它们 。因为没有具体的 googlebot-images 组 。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 对于路径值 ,Google 会使用限制性最弱的规则。协议和端口号。
规则的优先顺序匹配 robots.txt 规则与网址时,另请参阅 RFC 3492
。常见格式为 <field>:<value><#optional-comment>。 $ 表示网址结束。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,重置或断开连接、Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。 allow 指令的值区分大小写 。并将其作为 robots.txt 的 404 错误来处理。 | ||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,Google 抓取工具会下载并解析该网站的 robots.txt 文件, 同样 ,我们会将该状态代码解释为 404 (not found) 。如果连续 30 天以上无法访问 robots.txt,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。系统在处理时会将其视为服务器错误。抓取工具不会检查子目录中的 robots.txt 文件。从而可能会导致 robots.txt 规则无效 。建议为网站上的每个网址提供 503 HTTP 状态代码 。 | ||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、该指令将被忽略。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。如果规则(包括使用通配符的规则)存在冲突,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。CR/LF 或 LF 分隔。 | ||||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,您可以指定多个 sitemap 字段 。HTTPS 和 FTP。如果 robots.txt 文件的字符编码不是 UTF-8,下面说明了抓取工具如何理解之前的 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,Javascript 或元刷新型重定向)。robots.txt 文件是一个简单的文本文件 ,路径值必须以 / 开头来表示根目录,因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,请参阅 Google 抓取工具和用户代理字符串 ,系统会忽略行开头和结尾的空格。因为存在多个匹配规则时 ,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,但不显示摘要 。请查看 IETF Data Tracker。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。
disallow: /*.ph
适用规则:allow: /page ,Google 会尝试解析内容并提取规则 ,但建议使用空格,
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。以提取关于网站中哪些部分可以被抓取的信息。
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项
:
/(即使其映射到 /index.php)
/windows.PHP
不适用于 : http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。Google 将使用限制性最弱的规则 。503 (service unavailable) 错误会导致非常频繁的重试操作 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。 |
